Лабораторная работа №3_Робот_цикл Nраз

Лабораторная работа № 3.
Составление циклических алгоритмов для исполнителя РОБОТ.
Цикл N раз. Вложенные циклы.

Цель работы: Научиться составлять циклические алгоритмы для исполнителя РОБОТ.

Теоретические сведения:
Система команд исполнителя Робот включает:
Команды действия:

Команды проверки:
Команды измерения:

Для краткой записи серии повторяющихся действий в алгоритме можно использовать составную команду Цикл N раз.
Общий вид цикла N раз:
нц N раз

· тело_цикла
кц
Здесь N целое выражение, задающее число повторений. При выполнении алгоритма последовательность команд циклически повторяется указанное число раз.
Ход работы:
На диске D: в папке STUDENT создать папку со своей фамилией. В этой папке создать папку Лабораторная работа №3.
Загрузить систему Кумир. Убрать значок комментария для активизации Робота.
Настроить стартовую обстановку Робота согласно задач своего варианта. Для этого вызвать на экран редактор обстановки и пользуясь подсказкой, создать стартовую обстановку.
Написать алгоритмы для Робота. Проверить правильность алгоритмов, вызвав на экран Окно наблюдения за Роботом.
Составить отчет по лабораторной работе. Для этого создать текстовый документ в Word. В документе написать:
- тему и цель лабораторной работы
- свою фамилию, имя, № группы
- номер варианта.
- задания
Скопировать окна с текстом программы (Alt+PrtSc) и вставить в отчет.
Скопировать окна наблюдения за Роботом с результатом выполненной программы (Alt+PrtSc) и вставить в отчет.

Примеры выполнения задания:
Пример 1.
Составить алгоритм перемещения Робота из т.А в т.В и закрашивания помеченных клеток.
Настраиваем стартовую обстановку Робота согласно задания. Сохраняем ее в свою папку под именем z2.fil

Составляем алгоритм для Робота.








Открываем окно наблюдения за Роботом и запускаем алгоритм: Меню - Выполнение – Выполнить непрерывно.

Пример 2.
Составить алгоритм перемещения Робота из т.А в т.В и закрашивания помеченных клеток.

В данной задаче Робот должен выполнить 4 раза следующую последовательность действий:












Пример 3. Использование вложенных циклов.
Составить алгоритм перемещения Робота из т.А в т.В и закрашивания помеченных клеток.

Для того, чтобы закрасить один ряд, вернуться назад и приготовиться для закрашивания следующего ряда, нужно выполнить такие действия:












Чтобы закрасить все клетки, нужно выполнить эту последовательность действий 5 раз. После этого Робот будет находиться в клетке, на которую указывает стрелка. Последние два цикла переводят Робота в точку В.














Задания к лабораторной работе:
Выполнить 2 задания. Оформить заголовки алгоритмов, как в заданиях.
Вариант 1
Задание 1.

использовать Робот алг Закрасить помеченные клетки . дано | Робот в клетке A . надо | Все помеченные клетки закрашены | Используйте циклы нц ... раз для закраски однотипных фрагментов


Задание 2.
использовать Робот
алг Переместить робота из A в B, закрасив помеченные клетки
. дано | Робот в клетке A
. надо | Переместите робота в клетку B
| Все помеченные клетки должны быть закрашены
| Используйте вложенные циклы



Вариант 2
Задание 1.

использовать Робот
алг Закрасить помеченные клетки.
дано | Робот в клетке A.
надо | Все помеченные клетки закрашены
| Используйте циклы нц ... раз для закраски однотипных фрагментов



Задание 2.
использовать Робот
алг Переместить робота из A в B, закрасив помеченные клетки
. дано | Робот в клетке A
. надо | Переместите робота в клетку B
| Все помеченные клетки должны быть закрашены
| Используйте вложенные циклы


Вариант 3
Задание 1.

использовать Робот
алг Закрасить помеченные клетки.
дано | Робот в клетке A.
надо | Все помеченные клетки закрашены
| Используйте циклы нц ... раз для закраски однотипных фрагментов



Задание 2.
использовать Робот
алг Переместить робота из A в B, закрасив помеченные клетки
. дано | Робот в клетке A
. надо | Переместите робота в клетку B
| Все помеченные клетки должны быть закрашены
| Используйте вложенные циклы





Вариант 4
Задание 1.

использовать Робот
алг Закрасить помеченные клетки.
дано | Робот в клетке A.
надо | Все помеченные клетки закрашены
| Используйте циклы нц ... раз для закраски однотипных фрагментов


Задание 2.
использовать Робот
алг Переместить робота из A в B, закрасив помеченные клетки
. дано | Робот в клетке A
. надо | Переместите робота в клетку B
| Все помеченные клетки должны быть закрашены
| Используйте вложенные циклы


Вариант 5
Задание 1.

использовать Робот
алг Закрасить помеченные клетки.
дано | Робот в клетке A.
надо | Все помеченные клетки закрашены.
|Переместите Робота в клетку В
| Используйте циклы нц ... раз для закраски однотипных фрагментов


Задание 2.
использовать Робот
алг Переместить робота из A в B, закрасив помеченные клетки
. дано | Робот в клетке A
. надо | Переместите робота в клетку B
| Все помеченные клетки должны быть закрашены
| Используйте вложенные циклы


Вариант 6
Задание 1.

использовать Робот
алг Закрасить помеченные клетки.
дано | Робот в клетке A.
надо | Все помеченные клетки закрашены
|Переместите Робота в клетку В
| Используйте циклы нц ... раз для закраски однотипных фрагментов



Задание 2.
использовать Робот
алг Переместить робота из A в B, закрасив помеченные клетки
. дано | Робот в клетке A
. надо | Переместите робота в клетку B
| Все помеченные клетки должны быть закрашены
| Используйте вложенные циклы


Вариант 7
Задание 1.

использовать Робот
алг Закрасить помеченные клетки.
дано | Робот в клетке A.
надо | Все помеченные клетки закрашены
| Используйте циклы нц ... раз для закраски однотипных фрагментов



Задание 2.
использовать Робот
алг Переместить робота из A в B, закрасив помеченные клетки
. дано | Робот в клетке A
. надо | Переместите робота в клетку B
| Все помеченные клетки должны быть закрашены
| Используйте вложенные циклы


Вариант 8
Задание 1.

использовать Робот
алг Закрасить помеченные клетки.
дано | Робот в клетке A.
надо | Все помеченные клетки закрашены
| Используйте циклы нц ... раз для закраски однотипных фрагментов


Задание 2.
использовать Робот
алг Переместить робота из A в B, закрасив помеченные клетки
. дано | Робот в клетке A
. надо | Переместите робота в клетку B
| Все помеченные клетки должны быть закрашены
| Используйте вложенные циклы



Вариант 9
Задание 1.

использовать Робот
алг Закрасить помеченные клетки.
дано | Робот в клетке A.
надо | Все помеченные клетки закрашены
| Используйте циклы нц ... раз для закраски однотипных фрагментов


Задание 2.
использовать Робот
алг Переместить робота из A в B, закрасив помеченные клетки
. дано | Робот в клетке A
. надо | Переместите робота в клетку B
| Все помеченные клетки должны быть закрашены
| Используйте вложенные циклы


Вариант 10
Задание 1.

использовать Робот
алг Закрасить помеченные клетки.
дано | Робот в клетке A.
надо | Все помеченные клетки закрашены
| Используйте циклы нц ... раз для закраски однотипных фрагментов


Задание 2.
использовать Робот
алг Переместить робота из A в B, закрасив помеченные клетки
. дано | Робот в клетке A
. надо | Переместите робота в клетку B
| Все помеченные клетки должны быть закрашены
| Используйте вложенные циклы


использовать Робот
алг Ряд
нач
нц 6 раз
вправо
закрасить
кц
вправо
кон

вверх
вправо
вниз
закрасить
вверх
вправо
вниз

использовать Робот
алг Ряд
нач
влево
вверх
нц 4 раз
вверх
вправо
вниз
закрасить
вверх
вправо
вниз
кц
вверх
кон

нц 6 раз
вправо
закрасить
кц
вниз
нц 6 раз
влево
кц

использовать Робот
алг Прямоугольник
нач
нц 5 раз







кц
нц 7 раз вправо кц
нц 5 раз вверх кц
кон

нц 6 раз
вправо
закрасить
кц
вниз
нц 6 раз влево кц

Вложенный цикл – это цикл внутри другого цикла.



Picture 2Picture 2Picture 3Рисунок 1Рисунок 1Рисунок 1Рисунок 1Рисунок 1Рисунок 1Рисунок 1Рисунок 1Рисунок 1Рисунок 115

Приложенные файлы

  • doc 19296571
    Размер файла: 1 000 kB Загрузок: 0

Добавить комментарий