Лабораторная работа 2 Excel

Лабораторная работа №2. Логические функции.
1 лист переименовать как “стипендия ”
Создать следующую таблицу

B
C
D
E
F
G
H

2

Начисление стипендии




3
Студент
История
Физика
Алгебра
Ср.балл
Стипендия 1
Стипендия 2

4
Иванов
4
5
4




5
Петров
3
3
4




6
Сидоров
2
3
2




7








8
Размер стипендии
500





9









Средний бал высчитать по формуле: =СРЗНАЧ(C4:E4);
Формула либо набирается вручную в ячейке F4, либо выполняется следующий алгоритм: Встать в ячейку F4, поставить знак равно, далее меню вставка – функция – статистические – СРЗАЧ(). Убедиться, что в строке число стоит C4:E4, иначе нажать на маркер в конце строки, обвести мышкой ячейки C4:E4, нажать на маркер, ОК.
Вытянуть формулу на оставшиеся ячейки.
Рассчитаем стипендию по 1 варианту: если средний балл выше 4, начислим стипендию, иначе начислять стипендию не будем. Для данного вычисления запишем в ячейку G4 формулу =ЕСЛИ(F4>4;$D$8;0)
Рассчитаем стипендию по 2 варианту: если средний балл больше 4, то начислим повышенную (в 1,5 раза) стипендию, если средний балл меньше 4, но больше 3, начислим стипендию в обычном размере, иначе стипендию начислять не будем. Для данного вычисления запишем в ячейку H4 формулу =ЕСЛИ(F4>4;$D$8*1,5;ЕСЛИ(F4>3;$D$8;0))
Переименовать лист2 как “Телефон”.
Создать следующую таблицу

B
C
D
E
F

2
Начисление платы за междугородние разговоры

3
Абонент
Время разговора
Длительность в мин
Плата за разговор


4
Иванов
8:30
2



5
Петров
19:40
5



6
Сидоров
23:10
4



7






8
Тариф
50
Диапазон
8:00


9



18:00


10



22:00


Не забудьте задать временной формат для соответствующих ячеек.
Сумма начисляется следующим образом: Тариф = 50 рублей за 1 минуту разговора.
Если звонок произведен с 8.00 до 18.00, то за 1 минуту взимается тройной тариф. Если звонок произведен с 18.00 до 22.00, то за 1 минуту взимается двойной тариф. Если звонок произведен с 22.00 до 8.00, то за 1 минуту взимается одинарный тариф. Для реализации данного алгоритма в ячейку E4 запишем формулу:
=ЕСЛИ(И(C4>$E$8;C4<$E$9);$C$8*D4*3;ЕСЛИ(И(C4>$E$9;C4<$E$10);$C$8*D4*2;$C$8*D4))
Лист 3 переименовать “экология”.
Набрать таблицу


Выбросы в атмосферу

Вещество
Предприятие
Дата
количество
штраф

Азот
Комета
12.02.2006
200


Аммиак
Авиастар
11.03.2006
345


CO2
УАЗ
13.04.2006
100


Ртуть
Механический
12.03.2006
389


Кислота1
Авиастар
10.03.2006
290


Кислота2
УАЗ
12.02.2006
246


Фенол
УАЗ
01.03.2006
1000


Метан
Механический
03.02.2006
234


Тех.газ
Авиастар
18.02.2006
235


Водород
Авиастар
04.03.2006
257


Ниже таблицы набрать нормы выброса (столбец вещество можно скопировать)

Норма выброса в сутки

Азот
150


Аммиак
150


CO2
150


Ртуть
150


Кислота1
200


Кислота2
150


Фенол
800


Метан
356


Тех.газ
150


Водород
150


13. В ячейку D16 набрать Штраф, в Е16 – 300.
14. В таблице в ячейку штраф(напротив Азота) набрать формулу =ЕСЛИ(D5>B17;$E$16*(D5-B17);0), где D5- количество выбросов(Азот), В17 – норма выброса(Азот).
15. Вытянуть формулу на оставшиеся ячейки.
Выбор данных по условию
16.Выделить таблицу – выбросы в атмосферу.
17. Выбрать в меню: Данные – Фильтр - Автофильтор.
18. Выбрать Предприятие - Авиастар. Полученную таблицу скопировать ниже.
Вещество
Предприятие
Дата
количество
штраф

Аммиак
Авиастар
11.03.2006
345
58500

Кислота1
Авиастар
10.03.2006
290
27000

Тех.газ
Авиастар
18.02.2006
235
25500

Водород
Авиастар
04.03.2006
257
32100

19. Выбрать в меню: Данные – Фильтр - Автофильтор.
20. Повторить действие для остальных заводов.
21.Подсчитать итоговый штраф для каждого завода ( выделить ячейки под словом штраф, нажать знак суммы ).
Использование расширенного фильтра.
22. Скопировать в ячейку заголовок Предприятие. Скопировать в ячейку ниже Авиастар.
24. В ячейку рядом с ячейкой Авиастар вcтавить формулу:
Меню Вставка – функция - категория “Работа с базой данных”- БДСУММ.
25. В появившемся окне в строке база_данных щелкнуть по маркеру в конце строки, выделить всю таблицу вместе с заголовками и щелкнуть по маркеру в конце строки.
26. В строке поле щелкнуть по маркеру в конце строки, выделить ячейку штраф, щелкнуть по маркеру в конце строки.
27. В строке критерий щелкнуть по маркеру в конце строки, выделить ячейки, заполненные в пункте 22 (Предприятие, Авиастар), щелкнуть по маркеру в конце строки. Нажать ОК.
15

Приложенные файлы

  • doc 18760957
    Размер файла: 104 kB Загрузок: 0

Добавить комментарий